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Preface

NOTICE TO CUSTOMERS

document.

All documentation becomes dated, and this manual is no exception. Microchip tools and
documentation are constantly evolving to meet customer needs, so some actual dialogs
and/or tool descriptions may differ from those in this document. Please refer to our web site
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each
page, in front of the page number. The numbering convention for the DS number is
“DSXXXXXA”, where “XXXXX" is the document number and “A” is the revision level of the

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help.
Select the Help menu, and then Topics to open a list of available on-line help files.

INTRODUCTION

This chapter contains general information that will be useful to know before using the
Buck/Boost Converter PICtail™ Plus Daughter Board User’s Guide. Items discussed
in this chapter include:

Document Layout

Conventions Used in this Guide

Warranty Registration

Recommended Reading

The Microchip Web Site

Development Systems Customer Change Notification Service
Customer Support

Document Revision History

DOCUMENT LAYOUT

This document describes how to use the Buck/Boost Converter PICtail Plus Daughter
Board as a development tool to emulate and debug firmware on a target board. The
manual layout is as follows:

Chapter 1. “Introduction” — This chapter describes the Buck/Boost Converter
PICtail Plus Daughter Board and provides a brief description of the hardware.
Chapter 2. “Hardware Overview” — This chapter describes the board hardware.
Chapter 3. “Getting Started” — This chapter describes the step-by-step process
for getting your board up and running with the MPLAB® In-Circuit Debugger 2
(ICD 2) using a dsPIC33FJ16GS502 device.

Chapter 4. “Demonstration Program Operation” — This chapter describes the
operation of the board.

Appendix A. “Schematics and Layouts” — This appendix illustrates the layout
and provides hardware schematic diagrams for the board.

Appendix B. “Bill of Materials (BOM)” — This appendix provides the Bill of
Materials (BOM) for the board.

© 2010 Microchip Technology Inc. DS70336B-page 5
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description

Represents

Examples

Arial font:

Italic characters

Referenced books

MPLAB® IDE User’s Guide

Emphasized text

...Is the only compiler...

dialog

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer
Quotes A field name in a window or | “Save project before build”

Underlined, italic text with A menu path File>Save
right angle bracket
Bold characters A dialog button Click OK

A tab

Click the Power tab

N‘Rnnnn

A number in Verilog format,
where N is the total number of
digits, R is the radix and n is a
digit.

4'b0010, 2'hF1

Text in angle brackets < >

A key on the keyboard

Press <Enter>, <F1>

Courier New font:

Plain Courier New

Sample source code

#define START

Filenames autoexec.bat

File paths c:\mccl1l8\h

Keywords _asm, _endasm, static
Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants OXFF, “A”

Italic Courier New

A variable argument

file.o, where File can be
any valid filename

Square brackets [ ]

Optional arguments

mccl8 [options] file
[options]

Curly brackets and pipe
character: {| }

Choice of mutually exclusive
arguments; an OR selection

errorlevel {0]1}

Ellipses...

Replaces repeated text

var_name [,
var_name...]

Represents code supplied by
user

void main (void)
{ ...
}

DS70336B-page 6
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WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly.
Sending in the Warranty Registration Card entitles users to receive new product
updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING

This user’s guide describes how to use the Buck/Boost Converter PICtail™ Plus
Daughter Board. Other useful documents are listed below. The following Microchip
documents are available and recommended as supplemental reference resources.

Readme for Buck/Boost Converter PICtail™ Plus Daughter Board

For the latest information on using Buck/Boost Converter PICtail™ Plus Daughter
Board, read the Readme . txt text file in the Readme subdirectory of the MPLAB IDE
installation directory from the Buck/Boost Converter PICtail Plus Daughter Board CD.
The Readme file contains update information and known issues that may not be
included in this user’s guide.

Readme Files

For the latest information on using other tools, read the tool-specific Readme files in
the Readme subdirectory of the MPLAB IDE installation directory. The Readme files
contain updated information and known issues that may not be included in this user’s
guide.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web
site is used as a means to make files and information easily available to customers.
Accessible by using your favorite Internet browser, the web site contains the following
information:

« Product Support — Data sheets and errata, application notes and sample
programs, design resources, user’s guides and hardware support documents,
latest software releases and archived software

« General Technical Support — Frequently Asked Questions (FAQs), technical
support requests, online discussion groups, Microchip consultant program
member listing

* Business of Microchip — Product selector and ordering guides, latest Microchip
press releases, listing of seminars and events, listings of Microchip sales offices,
distributors and factory representatives

© 2010 Microchip Technology Inc. DS70336B-page 7
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DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip
products. Subscribers will receive e-mail notification whenever there are changes,
updates, revisions or errata related to a specified product family or development tool of
interest.

To register, access the Microchip web site at www.microchip.com, click on Customer
Change Notification and follow the registration instructions.

The Development Systems product group categories are:

e Compilers — The latest information on Microchip C compilers and other language
tools. These include the MPLAB C compiler; MPASM™ and MPLAB 16-bit
assemblers; MPLINK™ and MPLAB 16-bit object linkers; and MPLIB™ and
MPLAB 16-bit object librarians.

« Emulators — The latest information on Microchip in-circuit emulators.This
includes the MPLAB ICE 2000, MPLAB ICE 4000 and MPLAB REAL ICE.

* In-Circuit Debuggers — The latest information on the Microchip in-circuit
debugger, MPLAB ICD 2 and MPLAB ICD 3.

« MPLAB® IDE - The latest information on Microchip MPLAB IDE, the Windows®
Integrated Development Environment for development systems tools. This list is
focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager
and general editing and debugging features.

* Programmers — The latest information on Microchip programmers. These include
the MPLAB PM3 and PRO MATE® Il device programmers and the PICSTART®
Plus and PICkit™ 1, 2 and 3 development programmers.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

« Distributor or Representative

 Local Sales Office

 Field Application Engineer (FAE)

 Technical Support

Customers should contact their distributor, representative or field application engineer

(FAE) for support. Local sales offices are also available to help customers. A listing of
sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY

Revision A (August 2008)

This is the initial released version of this document.

Revision B (December 2010)

This revision of the document contains the following updates:

+ Added references to the dsPIC33FJ64GS610 device, which can be used with the
Explorer 16 Development Board throughout the document

* Added Appendix B. “Bill of Materials (BOM)”

« Formatting updates and minor changes to the text have been incorporated
throughout the document

DS70336B-page 8
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Chapter 1. Introduction

Modern power supplies are becoming smaller, more efficient, more flexible and less
expensive. These desirable enhancements have come about as digital signal controllers
(DSCs) are incorporated into Switch Mode Power Supply (SMPS) designs. Buck
converters are used when the desired output voltage is smaller than the input voltage.
Boost converters are used when the desired output voltage is higher than the input
voltage.

This chapter introduces and provides an overview of the Buck/Boost Converter PICtail
Plus Daughter Board. The following topics are included in this chapter:

* QOverview
¢ Features
* Product Package

1.1 OVERVIEW

The Buck/Boost Converter PICtail Plus Daughter Board (also referred to as Daughter
Board) is a power supply board. It consists of two independent DC/DC synchronous
buck converters and one independent DC/DC boost converter. Figure 1-1 illustrates a
block diagram of the Daughter Board.

All of the necessary power, drive and control signals are available in the J1 and J2 con-
nectors. The 16-bit 28-pin Starter Development Board can be used to control one inde-
pendent DC/DC synchronous buck converters. This board can also control two buck
stages, or one buck and one boost stage with hardware modification on the 16-bit
28-pin Starter Development Board. Refer to Section 2.4.2 “16-bit 28-pin Starter
Development Board Controls Buck 1 and Boost Stages” for more details.

The block diagram of the Daughter Board using the 16-bit 28-pin Starter Development
Board is illustrated in Figure 1-2. All three stages of the Buck/Boost Converter PICtail
Plus Daughter Board are controlled by the Explorer 16 Development Board. Figure 1-3
illustrates a block diagram of the Daughter Board using the Explorer 16 Development
Board.

The control boards provide closed-loop Proportional-Integral-Derivative (PID) control in
the software to maintain the desired output voltage level. The dsPIC® DSC device
provides the necessary memory and peripherals for A/D conversion, PWM generation,
analog comparison and general purpose I/O, excluding the need to perform these
functions in external circuitry.

SMPS dsPIC® DSC devices are specifically designed to provide low-cost and efficient
control for a wide range of power supply topologies. The specialized peripherals
facilitate closed-loop feedback control of switch mode power supplies, providing
communication for remote monitoring and supervisory control.

The Daughter Board enables the end user to easily transition from analog-to-digital
implementation of the power application. The Daughter Board also aids in rapid
development of buck converter, boost converter, multi-phase buck converter and two
parallel buck converters.

© 2010 Microchip Technology Inc. DS70336B-page 9
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The dsPIC33F SMPS family of devices provides the following features:

« Integrated program and data memory on a single chip
 Ultra-fast interrupt response time and hardware interrupt priority logic

« Up to 4 Msps, on-chip ADC with two SARs, and up to four dedicated and two
shared sample/hold circuits for multiple loop control

» Four independent, high-resolution PWM generators specially designed to support
different power topologies

« Four analog comparators for control loop implementation and system protection
« On-chip system communications (I2°C™/SPI/UART)

» On-chip Fast RC oscillator for lower system cost

 High-current sink/source for PWM pins: 16 mA/16 mA

e CPU performance: 40 MIPS

» Extensive power saving

e CodeGuard™ Security enabled

FIGURE 1-1: DAUGHTER BOARD BLOCK DIAGRAM
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FIGURE 1-2: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD WITH DAUGHTER BOARD
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FIGURE 1-3: EXPLORER 16 DEVELOPMENT BOARD WITH DAUGHTER BOARD
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1.2 FEATURES

The Buck/Boost Converter PICtail Plus Daughter Board provides the following
features:

121 Power Stages

< Two synchronous buck converter power stages

» One boost converter power stage

 Voltage/current measurement for digital control of buck converters
 Voltage/current measurement for digital control of boost converter

« Switchable, one 5¢Y5W resistive load on Buck Converter 1 output (VOUT1)
» Buck Converter 1 output (VOUT1) on J4 connector for external loading

« Buck Converter 2 output (VOUT?2) on J5 connector for external loading

« Boost Converter output (VOUT3) on J8 connector for external loading

» Connector J9 for auxiliary power input

1.2.2 Additional Features

* 5 kQ Potentiometer (RP1) connected via jumper J10

« Input voltage source selection via jumper J6

» Additional resistive load R46 via jumper J11

« Connectors J1 and J2 (Explorer 16/16-bit 28-pin Starter Development Board)
¢ PMBus™ Connector (J3)

1.2.3 Daughter Board Power

 Auxiliary power input (J9): +7V to +15V (+9V nominal)
* 9V power input is through input connectors J2 and J1
LED power-on indicator (D14)

« LED output voltage indicators (D11, D12 and D13)

Note: The 9V input is supplied from the controller card (16-bit 28-pin Starter
Development Board or Explorer 16 Development Board). All 16-bit 28-pin
Starter Development Boards should have a blue wire connecting Pin 1 of
J1 to Pin 28 of J2. If no blue wire connects them, connect a wire between
them to supply the 9V input to the Buck/Boost Converter PICtail Plus
Daughter Board.

1.3 PRODUCT PACKAGE

The Buck/Boost Converter PICtail Plus Daughter Board kit consists of the following
items:

» Buck/Boost Converter PICtail Plus Daughter Board

« Buck/Boost Converter PICtail Plus Daughter Board CD

The CD consists of the application software, example code, Readme file and User’s
Guide.

© 2010 Microchip Technology Inc. DS70336B-page 13
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Chapter 2. Hardware Overview

This chapter lists and describes the hardware elements and components of the
Buck/Boost Converter PICtail Plus Daughter Board (also referred to as Daughter
Board). The following topics are included:

« Daughter Board Connectors

« Daughter Board User Hardware Interface

 Using the Daughter Board with the Explorer 16 Development Board

« Using the Daughter Board with the 16-bit 28-pin Starter Development Board

« Power Rating of Converter Stages

2.1 DAUGHTER BOARD CONNECTORS

The Daughter Board consists of different power sections along with the input and
output connectors for signal and power connections. Figure 2-1 shows the Daughter
Board, the input and output connectors and their locations.

FIGURE 2-1: BUCK/BOOST CONVERTER PICtail™ PLUS DAUGHTER BOARD
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J1 — To connect Explorer 16 Development Board

J2 — To connect 16-bit 28-pin Starter Development Board
J3 — PMBus™ interface connector

J4 — VOUT1 connector

N

5. J5-VOUT2 connector
6. J8 — VOUT3 connector
7. J9 — Auxiliary input power connector
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Note: The Daughter Board only consists of the three power trains of the DC/DC
converter sections. Either the 16-bit 28-pin Starter Development Board with
the dsPIC33FJ16GS502 device, or the Explorer 16 Development Board
with the dsPIC33FJ16GS504 or dsPIC33FJ64GS610 device can be used
to control the DC/DC power sections of the Daughter Board. The J1 and J2
connectors provide the necessary signals for control purposes.

2.2 DAUGHTER BOARD USER HARDWARE INTERFACE

This section describes the hardware interface of the Daughter Board and the power
rating of each converter’s section. Figure 2-2 shows the hardware elements (pin
headers, jumpers, LED and potentiometer).

FIGURE 2-2: BUCK/BOOST CONVERTER PICtail™ PLUS DAUGHTER BOARD HARDWARE
ELEMENTS
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2.2.1 Auxiliary Input Power Connector

The Daughter Board can be connected to the auxiliary/bench power DC source through
the J9 input connector. Jumper J6 should be removed while working with the
auxiliary/bench power DC source. See Figure A-5 for the location of this jumper.

2.2.2 PMBus Interface Connector J3

The Daughter Board allows the user to implement the PMBus on the SMPS dsPIC DSC
device using the J3 connector. See Figure A-6 for the location of this jumper.

DS70336B-page 16 © 2010 Microchip Technology Inc.
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2.2.3 16-bit 28-pin Starter Development Board Connector J2

The two converter stage sections of the Daughter Board can be controlled using the
16-bit 28-pin Starter Development Board. Table 2-1 lists all the power and signal

connections on the Daughter Board J2 connector to the user interface with the 16-bit
28-pin Starter Development Board. See Figure A-6 for the location of this connector.

TABLE 2-1: SIGNAL AND POWER CONNECTION FOR 16-BIT 28-PIN
STARTER DEVELOPMENT BOARD (J2)
Pin Number Assignment Primary Use
Primary

1 NC Not Connected
2 ANO Analog Input 0 (Buck Converter 1 current)
3 AN1 Analog Input 1 (Buck Converter 1 voltage)
4 AN2 Analog Input 2 (Buck Converter 2 current)
5 AN3 Analog Input 3 (Buck Converter 2 voltage)
6 AN4 Analog Input 4 (Input Voltage)
7 NC Not Connected
8 Vss Ground reference for logic and 1/O pins
9 NC Not Connected
10 NC Not Connected
11 NC Not Connected
12 NC Not Connected
13 VDD Positive supply for logic and 1/O pins
14 NC Not Connected
15 RB15 PMBUSAUX2
16 RB5 PMBUSAUX1
17 SCL SCL/TX
18 SDA SCL/RX
19 Vss Ground reference for logic and 1/O pins
20 VDD +3.3V_DIG
21 PWM3H PWM Boost Converter
22 I/10 Load
23 PWM2H PWM 2 High Output (Buck Converter 2)
24 PWM2L PWM 2 Low Output (Buck Converter 2)
25 PWM1H PWM 1 High Output (Buck Converter 1)
26 PWM1L PWM 1 Low Output (Buck Converter 1)
27 NC Not Connected
28 +9V Input Voltage for two buck stages

© 2010 Microchip Technology Inc.
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224 Explorer 16 Development Board Connector J1

The two buck sections and one boost section of the Daughter Board can be controlled
using the Explorer 16 Development Board. Table 2-2 lists all the power and signal
connections on the Daughter Board J1 connector to the user interface with the
Explorer 16 Development Board. See Figure A-6 for the location of this connector.

TABLE 2-2: SIGNAL AND POWER CONNECTION FOR THE EXPLORER 16
DEVELOPMENT BOARD (J1)
Pin Number Assignment Primary Use
Primary
79 ANO Analog Input 0 (Buck Converter 1 current)
80 AN1 Analog Input 1 (Buck Converter 1 voltage)
45 PWM1H PWM 1 High Output (Buck Converter 1 drive)
46 PWM1L PWM 1 Low Output (Buck Converter 1 drive)
8 AN2 Analog Input 2 (Buck Converter 2 current)
6 AN3 Analog Input 3 (Buck Converter 2 voltage)
12 PWM2H PWM 2 High Output (Buck Converter 2 drive)
11 PWM2L PWM 2 Low Output (Buck Converter 2 drive)
50 AN4 Analog Input 4 (Input Voltage)
102 ANS Analog Input 8 (Boost Converter Voltage)
80 AN9 Analog Input 9 (Boost Converter Voltage)
17 PWM3H PWM3H High Output (Boost Converter drive)
13 I/O Load Drive for Buck Converter 1 Load
101 AN10 Analog Input 10 (POT RP1)
65 RB15 PMBUSAUX2
66 RB5 PMBUSAUX1
67 SCL SCL/TX
68 SDA SCL/RX
9, 10, 119, 120 3.3VDIG_GND Ground Reference for Digital 1/0 pins
21, 22, 53, 54, +3.3V_DIG Digital 3.3V
107, 108
15, 16, 41, 42 9VANA_GND Ground Reference for Logic and 1/O pins
25, 26, 57, 58 +9V 9V Input Voltage
1-5, 14, 18-20, 23, NC Not Connected
24, 27-30, 33-40,
43, 44, 49, 51, 52,
55, 56, 59-62,
69-78, 81-95,
97-100, 103-106,
109-118

DS70336B-page 18 © 2010 Microchip Technology Inc.




Hardware Overview

2.25  VOUTL J4 (Buckl+)

An external load can be connected to VOUT1 through the J4 connector. One
on-board parallel resistor, R44 (5CQY5W), is connected at the output of VOUTL1 through
MOSFET Q13 to optionally load the Buck 1 converter circuit. Resistor R45 is
on-board, and there is space to solder resistor R46 onto the board. When resistor
R46 is connected to VOUT1, the J11 jumper must be open while working with +9V
power from the control board. The on-board load resistor can be connected to
VOUT1 by controlling the signal name “Load”. The “Load” signal is the 1/O pin of the
SMPS dsPIC DSC device, and is active-high. See Figure A-2 for the location of this
connector.

2.2.6  VOUT2 J5 (Buck2+)

An external load can be connected to VOUT2 through the J5 connector. VOUT2
can load up to a maximum of 3 amps when the auxiliary input voltage source is
connected at the J9 input connector. See Figure A-3 for the location of this
connector.

2.2.7 VOUT3 J8 (Boost)

An external load can be connected to VOUT3 through the J8 connector. VOUT3 can
load up to 0.75 amps when the auxiliary input voltage source is connected at the J9
input connector. See Figure A-4 for the location of this connector.

2.2.8 Jumpers

The Daughter Board consists of three jumpers that determine its features. Table 2-3
lists jumpers and their functions.

TABLE 2-3: JUMPERS

Jumpers Description Default Configurations
J6 Select either 9V power provided by the Explorer 16 | Short with jumper header
Development Board or 16-bit 28-pin Starter (closed)
Development Board, and an external power supply
J10 Connects potentiometer RP1 to AN10 on Explorer | Open
16 Development Board
Jil Connects R46 load resistor to VOUT1 Open
J12 Buck 2 voltage feedback selection Short with jumper header
(closed)
J13 Buck 2 current feedback selection Short with jumper header
(closed)
J14 Boost current feedback selection Open
J15 Boost voltage feedback selection Open
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2.2.9 Potentiometer and LED

The Daughter Board consists of a potentiometer and LEDs for the user application.
Table 2-4 lists components and their functions.

TABLE 2-4: POTENTIOMETERS AND LED

Label Hardware Elements
RP1 Potentiometer connected to AN10 of Explorer 16 Development Board controller
D11 Buck 1 output LED
D12 Buck 2 output LED
D13 Boost output voltage LED
D14 Input voltage LED

2.2.10 Test Points

The Daughter Board provides the various test points of the PWM signals, feedback
signals and input and output voltages for the user application. Table 2-5 lists the PWM
test points that can be used to check the PWM gate pulse for all three power stages.

TABLE 2-5: PWM TEST POINTS

Test Points Description
PWM1H Buck MOSFET gate drive of Buck 1 converter stage
PWM1L Synchronous MOSFET gate drive of Buck 1 converter stage
PWM2H Buck MOSFET gate drive of Buck 2 converter stage
PWM2L Synchronous MOSFET gate drive of Buck 2 converter stage
PWM3H Boost MOSFET gate drive for Boost converter stage

Table 2-6 lists the feedback signal test points that can be used to check the feedback
signal waveforms and values.

TABLE 2-6: FEEDBACK SIGNAL TEST POINTS
Test Points Description

Current Sensel | Current feedback signal for Buck 1 converter stage
Current Sense2 | Current feedback signal for Buck 2 converter stage
Current Sense3 | Current feedback signal for Boost converter stage

Table 2-7 shows the power test points that can be used to verify the input and output
voltages.

TABLE 2-7: POWER TEST POINTS

Test Points Description
V+ Input Voltage Test Point
Buckl+ VOUTL1 voltage test point
Buck2+ VOUT2 voltage test point
Boost+ VOUTS3 voltage test point
GND Ground potential test point
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2.3 USING THE DAUGHTER BOARD WITH THE EXPLORER 16
DEVELOPMENT BOARD

This section describes the hardware connection of the Daughter Board with the
Explorer 16 Development Board. Figure 2-3 shows the Daughter Board hardware
connection (MPLAB ICD 2 and power supply) to the Explorer 16 Development Board.

The dsPIC33FJ16GS504 or dsPIC33FJ64GS610 SMPS device controls both buck
stages (Buck 1 and Buck 2), as well as the boost stage through the Explorer 16
Development Board simultaneously.

Note: To operate all three converters using the Explorer 16 Development Board,
ensure that J12, J13 and J6 are shorted with the jumper header, and J14
and J15 are open before powering up the board.

The potentiometer R6 (10 kQ), in series with the R12 resistor on the Explorer 16
Development Board, is connected to analog input channel (AN5) of the SMPS dsPIC
DSC device. The potentiometer R6 on the Daughter Board is connected to the analog
input channel (AN10) through the J10 jumper. Both potentiometers can be used for
development purposes to simulate any feedback signal.

FIGURE 2-3: DAUGHTER BOARD CONNECTED TO THE EXPLORER 16 DEVELOPMENT
BOARD

MPLAB® ICD 2
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2.4 USING THE DAUGHTER BOARD WITH THE 16-BIT 28-PIN STARTER
DEVELOPMENT BOARD

FIGURE 2-4:

This section describes the use of a 16-bit 28-pin Starter Development Board with the
Buck/Boost Converter PICtail Plus Daughter Board.

Figure 2-4 shows the 16-bit 28-pin Starter Development Board and its hardware
elements. For more details, refer to the “16-bit 28-pin Starter Development Board
User's Guide” (DS51656), which is available from the Microchip web site
(http://www.microchip.com).

16-BIT 28-PIN STARTER DEVELOPMENT BOARD
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The potentiometer, RP1 (10 k), with the J5 jumper on the 16-bit 28-pin Starter
Development Board, is connected to the analog input channel (AN5) of the SMPS
dsPIC DSC device. Figure 2-5 shows the connection of a 16-bit 28-pin Starter
Development Board to a Daughter Board with ICD 2 and a 9V power supply.

Ensure that the following changes are made to the 16-bit 28-pin Starter Development
Board prior to connecting the 16-bit 28-pin Starter Development Board to the Daughter
Board:

* Remove resistors R14 and R15 (to control Buck 2 or Boost converter)

e JP1 in pin 1-2 position (supply)

* JP2 in pin 2-3 position (+3.3V)

JP3in 1-2 position (dsPIC33F/PIC24)

JP4 open

SW2 in USB/DEBUG mode
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FIGURE 2-5:

DAUGHTER BOARD HARDWARE CONNECTED TO A 16-BIT 28-PIN STARTER
DEVELOPMENT BOARD

MPLAB® ICD 2
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24.1 16-bit 28-pin Starter Development Board Controls Buck 1 and

Buck 2 Stages (Default Jumper Configuration)

The dsPIC33FJ16GS502 SMPS device controls buck stages Buck 1 and Buck 2
through the 16-bit 28-pin Starter Development Board as the default configuration on the
Daughter Board, refer to Table 2-3. The two buck stages can be controlled as

multi-phase or as two parallel converters by shorting the VOUT1 (Buck1+) and VOUT2

(Buck2+) output, and by programming the output of buck stages to the same output
voltage value.

Note 1: To operate the two buck converters using the 16-bit 28-pin Starter Devel-
opment Board, ensure that J12, J13 and J6 are shorted with the jumper
header, and J14 and J15 are open before powering up the board.

2:

The software file Buckl Voltage Mode with 28P Starter Board

on the Buck/Boost Converter PICtail Plus Daughter Board CD only
provides control for the Buck 1 stage.
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2.4.2 16-bit 28-pin Starter Development Board Controls Buck 1 and
Boost Stages

This section describes the hardware changes that must be performed to control the
Buck 1 and Boost stages. Figure 2-6 displays the feedback jumper, which must be
modified in the Daughter Board. See Figure A-4 for the complete Daughter Board
schematics.

FIGURE 2-6: FEEDBACK JUMPERS

PWM3H

2.42.1 HARDWARE
The following hardware changes are required in the Daughter Board to enable control
of the Buck 1 and Boost stage:

e Jumper J12 and J13: Open
e Jumper J14 and J15: Short with jumper header (close)

2422 SOFTWARE

The following additional changes in software are required to enable control of the Buck
1 and Boost stage:

« Boost Current feedback through analog input channel (AN2)

» Boost Voltage feedback through analog input channel (AN3)

« Boost PWM output (PWM3H)

* PWM2 output pin must be controlled by I/O port and driven low

Note: The software file Buckl Voltage Mode with 28P Starter Board
on the Buck/Boost Converter PICtail Plus Daughter Board CD only provides
control for the Buck 1 stage.
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2.5 POWER RATING OF CONVERTER STAGES

All three DC/DC power stages in a Daughter Board can be loaded externally through
the output terminal blocks J4, J5 and J8. For loading any power stage externally, the
user must provide an auxiliary power source to the Daughter Board through input
terminal block J9.

2.5.1 Buck 1 Converter

The Buck 1 converter stage is rated for a maximum output current of 3 amps through
the J4 connector. The output voltage of the buck converter (VOUT1) can be pro-
grammed for OV-5V output. The hardware gain [5k/(3.3k + 5k)] of the voltage feedback
of VOUTL1 is provided by the resistor divider network of R11 and R12. The hardware
gain of the current feedback is provided by the current transformer (Tx1) with turns ratio
(1:60) and burden resistor R5. The circuitry consists of R6, R7, C7 and Q3, and
provides slope compensation for current feedback (Current Sensel).

2.5.2 Buck 2 Converter

The Buck 2 converter stage is rated for a maximum output current of 3 amps through
the J5 connector. The output voltage of the buck converter (VOUT2) can be pro-
grammed for OV-5V output. The hardware gain [5k/(3.3k + 5k)] of the voltage feedback
of VOUT?2 is provided by the resistor divider network of R29 and R30. The hardware
gain of the current feedback is provided by the current transformer (Tx2) with turns ratio
(1:60) and burden resistor R23. The circuitry consists of R24, R25, C14 and Q8, and
provides slope compensation for current feedback (Current Sense?2).

2.5.3 Boost Converter

The Boost converter stage is rated for a maximum output current of 0.75 amps through
the J8 connector. The output voltage of the boost converter (VOUT3) can be
programmed up to a maximum output of 20V. The hardware gain [20k/(20k + 3.3k)] of
the voltage feedback of VOUT3 is provided by the resistor divider network of R55 and
R56. The hardware gain of the current feedback is provided by the current sense
resistor R53 (current sense boost/Current Sense3). The circuitry consists of R13, R14,
C20 and Q4 and provides slope compensation for current feedback

(current sense boost/Current Sense3).
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NOTES:
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Chapter 3. Getting Started

This chapter provides details to get started using the Daughter Board with the 16-bit
28-pin Starter Development Board using the dsPIC33FJ16GS502 SMPS device. The
16-bit 28-pin Starter Development Board is modified as per Section 2.4 “Using the
Daughter Board with the 16-bit 28-pin Starter Development Board”. While working
with the Daughter Board along with the Explorer 16 Development Board using a
dsPIC33FJ16GS504 device, please refer to the Explorer 16-specific note that is
specified in the corresponding instructions.

The following topics are covered in this chapter:

* Overview

 Creating the Project
 Building the Code

* Programming the Device
» Debugging the Code

3.1 OVERVIEW

This section describes the main features of MPLAB IDE and the MPLAB ICD 2
In-Circuit Debugger because they are used in the 16-bit 28-pin Starter Development
Board. This section provides information on performing the following tasks:

1. Creating a project using the Project Wizard.

Assembling and linking the code, and setting the Configuration bits.
Setting up MPLAB IDE to use the MPLAB ICD 2 In-Circuit Debugger.
Programming the chip with MPLAB ICD 2.

Viewing code execution.

Viewing registers in the Watch window.

Setting a breakpoint and setting the code halt in the specific location.

8. Using the function keys to Reset, Run, Halt and Single Step the code.

Before performing these steps, save the Buck/Boost Converter PICtail Plus Daughter
Board firmware from the CD in the following location: C:\Program Files\Microchip\

No ok wDd

Note 1: The demo software using 16-bit 28-pin Starter Development Board will be
under folder: C:\Program Files\Microchip\Buck Boost
PICtail Plus Board\Buckl Voltage Mode with 28P Starter
Board.

2:  The demo software using Explorer 16 Development Board will be under
the folder: C:\Program Files\Microchip\Buck Boost PICtail
Plus Board\3-Stage Voltage Mode with Explorer 16

3: Both the above folders comprise of the project file (* .mcp) and
workspace file (* .mcw). The user can use these files to program the
device, or the user can create their own project and workspace file by
performing the steps listed in this Chapter.
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3.2 CREATING THE PROJECT

This section describes the process of creating a project and workspace in MPLAB IDE.
In any particular folder, one project and one workspace are present.

Note: These instructions presume the use of MPLAB IDE v8.10 or later. I

A project consists of files that are used to build an application (source code, linker script
files, etc.) along with their association to various build tools and build options. The
workspace consists of the following features:

« One or more projects

* Information on the selected device

» Debug tool and/or programmer, open windows and their location

» Other IDE configuration settings

MPLAB IDE provides a Project Wizard to create new projects.

3.21 Creating the Project

Using the Project Wizard involves four steps:

« Selecting the Device

 Selecting the Language Toolsuite

* Naming the Project

» Adding Files to the Project

Use the following procedures to complete each of the four steps.
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3.21.1 PROJECT WIZARD STEP ONE — SELECTING THE DEVICE

1. Start MPLAB IDE.

Close any open workspace (Eile>Close Workspace).

Select Project>Project Wizard. The Welcome dialog appears.
Click Next to continue. The Select a device dialog appears.

From the Device drop-down list, select the required device, as shown in
Figure 3-1.

aprwN

FIGURE 3-1: SELECT A DEVICE

Project Wizard

&3
EE:/%}

Step One:
Select a device

Device:

dzPIC33FITEG5502 w

¢ Back ” et » l[ Carnicel ][ Help

6. Click Next to continue. The Select a language toolsuite dialog appears, as
shown in Figure 3-2.

Note: While using the Explorer 16 Development Board, select the
dsPIC33FJ16GS504 or dsPIC33FJ64GS610 device.
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3.21.2 PROJECT WIZARD STEP TWO — SELECTING THE LANGUAGE
TOOLSUITE

1. Asshown in Figure 3-2, select Microchip C30 Toolsuite from the Active Toolsuite
drop-down list. This toolsuite includes the assembler and linker that is to be used
in the project.

Note: To create a project that consists of source files written in a language other
than Microchip Assembly, select the specific language toolsuite from the
drop-down menu.

FIGURE 3-2: SELECT LANGUAGE TOOLSUITE

Project Wizard

Step Two:
Select a languaage toolsuite

Active Toaolsuite: ticrachip C30 Toolzuite w

Toolzuite Contents
MPLAB ASK 30 Azzembler [pic30-az. exe ~

MPLAE C30 C Compiler [pic30-goc. exe]
MPLAE LIMNE30 Object Linker [pic30-1d. exe)
IR d e Trie 3020 seel

Location

C:%Program Files\MicrochipsMPLAR CA0Nbinspic30-gee. exd

Help! My Suite lsn't Listed! ] [ ] 5how all installed toolsuites

[ < Back ” M et » l[ Cancel ][ Help

2. Select MPLAB C30 C Complier (pic30-gcc.exe) from the Toolsuite Contents
options.

3. Click Next to continue. The Create a new project, or reconfigure the active
project? dialog appears, as shown in Figure 3-3.
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3.2.1.3 PROJECT WIZARD STEP THREE — NAME YOUR PROJECT
1. As shown in Figure 3-3, under Create New Project File, click Browse..., and
navigate to:

C:\Program Files\Microchip\Buck BoostPicTail Plus Board\Buckl
Voltage Mode with 28P Starter Board.

Note: While using the Explorer 16 Development Board, navigate to the following
path in the “Create New Project File”: C:\Program
Files\Microchip\Buck Boost PicTail Plus Board\3-Stage
Voltage Mode with Explorer 16.

FIGURE 3-3: NAME YOUR PROJECT
%
Step Three:

B
Create a new project, or reconfigure the active project? %/{::'}

—{* Create New Project File

C:AProgram FileshMicrochipBuck Boost PicT ail Plus Board4Buck1 Browse. .. I

— Eeconfigure Sctive Fraject
= ke changes without zaving

{° Save changes o existing praject file

{7 Save changes to another project file

Browse,.. |

< Back M et > | Cancel | Help |

2. Intheresulting Save Project As dialog, enter the project name as Buckl Voltage
Mode .mcp, and then click Save.

Note: While using the Explorer 16 Development Board, enter the project name as
3-Stage Voltage Mode.mcp.

3. Click Next to continue. The Add existing files to your project dialog appears, as
shown in Figure 3-4.
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3.214
1.

FIGURE 3-4:

Project Wizard

PROJECT WIZARD STEP FOUR — ADD FILES TO YOUR PROJECT

As shown in Figure 3-4, from the left pane, navigate to C:\ .. .\Buckl
Voltage Mode with 28P Starter Board, and select the following files:

e init.c

e isr.c

e main.c

e dsp.h

e function.h

= dspcommon.inc
e isr_asm.s

e pid.s

ADD FILES TO PROJECT

Step Four:
Add exizting files bo your project

B

EE}@

=-_] Buckl Woltage Mode wil;l A C:AProgram FileshMicrochiphBuck.
EH:I h ﬂl A C:\Program FileshMicrochiphB uck
I dsp h_ A C\Program Files\MicrochiphBuck
P Functions. h Remowve | A C:\Program FileshMicrochiphB uck,
EH:I ne ] I A C:AProgram Filest\MicrochiphBuck
{:I dspoommaning A C:MProgram FileshMicrochiphBuck
= : C " A C:AProgram FileshicrochiphBuck
e irik, ) . . .
_____ B e A C:AProgram FileshMicrochiphBuck.
= isr_asm.s
B main.c
i FE"I pid.s -
L« » KU — >
< Back | MHext » | Cancel | Help |

Click Add to include the files in the project. The selected files appear in the right

pane.

Click Next to continue. The Summary dialog appears as shown in Figure 3-5.

Note:

While using the Explorer 16 Development Board, navigate to the following

path: C:\program Files\Microchip\Buck Boost PICtail Plus
Board\3-Stage Voltage Mode with Explorer 16, and select the

following files:
e init.c
e isr.c
e main.c
e dsp.h
e function.h
e dspcommon.inc
e isr_asm.s
e pid.s
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3.215 PROJECT SUMMARY

Click Finish to complete the project.

FIGURE 3-5: SUMMARY DIALOG
X

Summary

Click “Finizh' to createdcanfigure the project with these
parameters.

Project Parameters
Dewice:  d:PICIIFNEGSE02

Toolsuite:  Micrachip C30 Toolzuite

File: C:“\Program Files\MicrochiphBuck Boost

A new workspace will be created. and the new project added
b that work zpace.

< Back I Finizh I Cancel Help

After completing the project wizard, the MPLAB IDE project window lists the following
files in the Source Files folder:

e isr.c

e main.c

e Isr_asm.s

e pid.s

e init.c

Note: While using the Explorer 16 Development Board, the MPLAB IDE project

window lists the following files in the Source Files folder:
- init.c
e isr.c
e main.c
e isr_asm.s
e pid.s
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3.2.1.6  VIEWING THE PROJECT
1. Click View>Project from the MPLAB IDE menu, as shown in Figure 3-6.

FIGURE 3-6: OPEN PROJECT FILE

& Buckl ¥oltage Mode - MPLAB IDE ¥8.10

File Edit | Wiew Project Debugger Programmer Tools  Configure
Pr E
Outpuk

Toolbars

P Registers

Zall Skack,
Disassembly Listing
EERROM

File Reqisters
Flash Data
Hardware Stack
Lz Picel

Locals

[Memory:

Program Memary
SER | Beripherals
Special Function Registers
Wakch

1 Mermory Usage Gauge

The Buckl Voltage Mode.mcw dialog appears, as shown in Figure 3-7. A
project, Buckl Voltage Mode.mcp, and workspace, Buckl Voltage
Mode .mcp, are created in MPLAB IDE.

Note: While using the Explorer 16 Development Board, the 3-Stage Voltage
Mode .mcp appears. A 3-Stage Voltage Mode.mcp project and
workspace, 3-Stage Voltage Mode.mcw, are created in MPLAB IDE.

DS70336B-page 34 © 2010 Microchip Technology Inc.



Getting Started

FIGURE 3-7: MPLAB® IDE PROJECT WINDOW

Il Buck1 Yoltage Mode .mcw -10] x|

=) [_1 Buck1 ¥oltage Mode .mcp
E||:I Source Files
-[2] init.c

isk.C

ist_asm.s
=] main.c

..... pid.s
=-I_ Header Files

..... dsp.h

----- Functions.h
..... E dspCornmon,ing
..... [ ohject Files

..... [ Library Files

----- [ Linker Scripk

..... [ other Files

< | 0

[ Files | “% Symbols

2. Double click the main.c file in the project window to open the file. The MPLAB
IDE Workspace Window appears, as shown in Figure 3-8. This completes the
project view process.
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. ®
FIGURE 3-8: MPLAB™ IDE WORKSPACE WINDOW
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#inelude "Funetions. h*
_FOSCSEL (FHOSC_FRC) _Ij
|1| | 3
|
| O

|dsPIC33FI16G5502

[

loabsab IP0 |denovzc |_|

Int, Gal1 s jwm

3.3 BUILDING THE CODE

Building the code consists of the following process:

» Assembling all of the *.c and *.s files to create the respective object files (*.0)
* Linking the object files to create the 3-Stage Voltage Mode.hex and
3-Stage Voltage Mode.cof output files

The .hex file contains the specific data to program the device. The . cof file contains
additional information to debug at the source code level.

Before building the code, the user must set MPLAB ICD 2 to search for include files
and to reserve space for the extra debug code.
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3.3.1 Building the Code

To specify the Project Build Options:

1. Select Build Options>Project from the Project menu. The Build Options For
Project “Buck 1 Voltage Mode.mcp” dialog appears, as shown in Figure 3-9.

FIGURE 3-9: BUILD OPTIONS
MPLAE ASM30 | MPLABCAD | MPLAB LINK30
Diectories | CustomBuild | Trace |  ASM30/C30 Suite

— Directariez and Search Paths

Show directaries far: IEIutput Drirechary j

MHew | [elete [z g |

Suite Defaultz |

— Build Directan Palicy
{* Agsemble/Compils in source-file directony, link in output directony

" fgsemble/Compilz/Link in the project directory

] Cancel Apply Help

2. Select Assemble/Compile/Link in the project directory, and then click OK. This
completes the code build process.

3.3.2 Linking the ICD 2 for Debugging

Select the Debug option from the drop-down menu of MPLAB IDE, as shown in
Figure 3-10, so the linker will build the code for debugging. This sets aside the RAM for
the MPLAB ICD 2 for use during debugging. If this is not performed, the MPLAB ICD 2
will not function properly in Debug mode.
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FIGURE 3-10:

LINK PROJECT FOR MPLAB® ICD 2

w Buck 1 Yoltage Mode - MPLAB IDE v8.10

File Edit Wiew Projeck Debugger  Programmer

Tools  Configure  Window  Help

DS ‘@ | S ?

J IDehug 'IE&?E = & B

3.3.3
To build the project:

Building the Project

1. Select Project>Build All from the MPLAB IDE menu, as shown in Figure 3-11.

FIGURE 3-11:

DualBuck MPLAB® IDE SCREEN

# Buck 1 Yoltage Mode - MPLAB IDE v8.10

Project Wizard. ..

File Edit “iew | Project Debugger Programmer Tools Configure  Window  Help

| D= |
Mew, ..
Open...
Close
Set Active Praject

Guickbuild

Clean

Excport Makefile
Build Al

Make

Build Configuration
Build Cptions. ..

Ckrl+F10

Save Project

Save Project As, ..

&dd Files to Project, ..
Add Mew File ko Project. ..
Remoyve File From Project

Select Language Toolsuite. ..

Wersion Control,..

Set Language Tool Locations. ..
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2. Observe the progress of the build in the Output window, as shown in Figure 3-12.
This completes the project build process.

The device can be programmed if the build status is BUILD SUCCEEDED. If the build
status is BUILD FAILED, the build errors that are listed must be resolved.

FIGURE 3-12: BUILD OUTPUT WINDOW

WWoutput o [=EY

Build | ‘ersion Contral | Find in Files | MPLAB ICD 2 |

=ection addres=s= alignment gaps total length (dec)
Lied O=800 0=50 0=50 (803
=zb== O=x850 u] O=E (B
nb== O0=x856 u] O=x=a (1070
nb=s O0=860 ] O=4 (43
ndata O=x864 ] O=2 (20
vh=s=s Oxffa u] O=x6 =D
Total data memory used (bytes): O=6c (1083 55X

Dynamic Hemory Usage

reJgion addre== maxinun length (dec)

heap ] u] [

stack OxE66 0=794 (1940}
Mazimum dynamic memory (bytes): 0=7194 (1940

Executing: "CAProgram Files\Microchip\MPLAB C30\bin\pic30-hinZhex exe" "CAProgram Files\Microchip\BuckBaoost
Loaded CA\Program Files\MicrochiphBuckBoostPICTail cardifirmeare\buckboosthoardy1 6-hit-28-pin-starer-board-cc

Cebug build of project "CAFrogram Files\MicrochiphBuckBoostFICT all cardifirmwarei\buckboosthoardy1 B-hit-28-pin-=
Freprocessor symbol __DEBUG' is defined.

Target debug platform is *__MPLAB_DEBUGGER_ICD2=1".

Debug plafform options are: " ICD2ZRAM=T".

Thu hdany 08 11:37:09 2008

BUILD SUCCEEDED ||

4] I o
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3.4 PROGRAMMING THE DEVICE

The MPLAB ICD 2 In-Circuit Debugger can be used to program and debug the
dsPIC33FJ16GS502 device in-circuit on the Daughter Board.

Note: Before proceeding, ensure that the USB driver for the MPLAB ICD 2 is
installed on your PC. Refer to the “MPLAB® ICD 2 In-Circuit Debugger
User’s Guide” (DS51331) for details.

34.1 Setting up the Device Configuration

1. Select Configure>Configuration Bits from MPLAB IDE to display the
configuration settings, as shown in Figure 3-13. The Configuration Bits window
appears, as shown in Figure 3-14.

FIGURE 3-13: CONFIGURATION MENU

','“- 16-hit-28-pin-starter-board-code-example - MPLAB IDE ¥3.10
File Edit View Project Debugger Programmer Tools | Configure  ‘Window Help

Dﬁﬂ\%hﬁ|@ﬁﬂ? JE Select Device, ..

Configuration

#E | Hhhe

0 SW BP INu Support j I

Exbernal Memar,. .
ID Mermary. ..

Settings...

2. Set the Configuration bits as highlighted in Figure 3-14.

FIGURE 3-14: CONFIGURATION SETTINGS
M Configuration Bits
[ Configuration Bits zat in code.

iddress | Value Category Setting

=qulnlulu] Qoor Boot ZJecment Write Protect Boot Zecmwent may he written
Boot 3egment Program Flash Code Protection Mo Boot Segment

Faooo4 aoav General Code Secwent Write Protect General Segwent mway be written
General Segment Code Protection No General ZJegment

FE0o06& FFFQ Oscillator Source Zelection Internal Fast RC (FRC) w/ PLL
Internal External Switch Orrer Mode Start up with FRC, then switch

Fao0os FF7E Primary Oscillator Source Primary Oscillator Disabled
05C2 Pin Function 03C0O pin has digital I/0 function
Peripheral Pin Select Configuration Lllow Only One Re-configuration
Cloc: Switching and Monitor 3w Enabled, Mon Disabled

FE0o04 FF7F Watchdog Timer Postscaler 1:32,7658
WDT Prescaler 1:128
Watchdog Timer Window Non-Window mode
Watchdog Timer Enakble Dizahle

Fg0oo0c FFF7 POR Timer Values 128ms
Brown-out Reset Enable Disahle

F2000E FFEE Commn Channel Select Use PGCZ/ENUCZ and PGDZ/EMUDZ
JTAG Port Enabhle Disabled
Iebugger/Emulation Ensble Bit Reset Into Operational Mode

1 4
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Connecting the MPLAB ICD 2 In-Circuit Debugger
Connect the MPLAB ICD 2 to the PC using the USB cable.

Connect the MPLAB ICD 2 to the 16-bit 28-pin Starter Development Board with
the short RJ-11 (telephone) cable. Apply +9V power to the 16-bit 28-pin Starter
Development Board.

3.4.2

1.
2.

FIGURE 3-15: DAUGHTER BOARD CONNECTED TO MPLAB® ICD 2 IN-CIRCUIT DEBUGGER

51 ,avdiN
< %mnoua\w
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3.4.3 Enabling the MPLAB ICD 2 Connection

1. Select Debugger>Select Tool>MPLAB ICD 2 to designate the MPLAB ICD 2 as
the debug tool in MPLAB IDE, as shown in Figure 3-16.

FIGURE 3-16: SELECTING THE DEBUGGER

% Buck 1 Yoltage Mode - MPLAE IDE v8.10

File Edit Wiew Project | Debugger Programmer Tools Configure  Window  Help
J 0= E | cll’lo [ ] Mone — i
Clear Memory L v 1 MPLAE ICD 2
J HW I % MPLAE ICE 4000
Furi F 3 MPLAE SIM
Animatz 4 MPLAB ICE 2000
H: " oReALICE
Step Inta F7 & PICKE 2
kep Over P8 Rican siarter ki
Shep Gk

Reset

Breakpaints...
Advanced Breakpoints. .,

MPLAE ICD 2 Setup YWizard,.,

Prograrm
Read
Read EEFROM

At Cperation

Conneck
Dawnload IC02 Operating Syskem

Settings. ..

2. Select Debugger>Connect to connect the debugger to the device.

The MPLAB ICD 2 should report that it found the dsPIC33FJ16GS502 device, as
shown in Figure 3-17.
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FIGURE 3-17: ENABLING MPLAB® ICD 2

MWouput =101 x|
Build | Wersion Control | Findin Files  MPLAB ICD 2

Fesetting Target

MFLAE ICD 2 Ready
Fesetting Target

MFLAE ICD 2 Ready
Fesetting Target

MFLAE ICD 2 Ready
Connecting to MFLAB CD 2
..Connected

Setfting Wdd source to target
Target Device dsPICI3FI1BGS502 found, revision = Rew 0x3000
..Reading ICD Froduct 1D
Funning ICD Self Test
..Fassed

MFLAE ICD 2 Ready

3. Select Debugger>Settings to display the MPLAB ICD 2 Debugger settings.
Select the Program tab on the Debugger settings dialog box.

5. Select the Allow ICD 2 to select memories and ranges radio button, as shown in
Figure 3-18. This setting will speed up operations by programming only a small
part of the total program memory.

&

Note: If this is the first time that the MPLAB ICD 2 is being used with a dsPIC33F
device, it may need to download the new firmware. If any errors are shown,
double click the error message to get more information.
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FIGURE 3-18: SETTING PROGRAM MEMORY SIZE
Wersionz I Wwlarnings I Secure Segment I Freeze |
Shatus I Cornrmunication I Lirnitations I Power Fragram

' Allow ICD 2 to select memaries and ranges

—1 Manually select memoriez and ranges

T hemoiee—— 7 [~ Froaram O ptions
¥ | Program
¥ | Corfiguration ¥ Eraze all before Program
[T EEFRDH ™| Frezene EEFEDRM on Frogram
i
[T Ezternal
= Bragram Meman—— 7 = Ertermal Memary
[Fes] [Fres]
Start IEI:-:EI Start IEI:-:EI
Etd IDH4FF End IEI:-:EI
Full Hangel Full B anme |

— Bootlaader
[Hzer Memary B outines

IHIEDIZHSFL-‘-‘-.WE.HEX Browse... |

— Automatically

[™ Program after successful build

[ Fiun after successiul program

| F, I Cancel Lpply Help
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344 Programming the dsPIC33FJ16GS502 Device

To program the device:
1. From the Debugger, select Debugger>Program.

The Output (Program Memory window), as shown in Figure 3-19, displays the
program statuses as they appear.

FIGURE 3-19: PROGRAMMING THE dsPIC33FJ16GS502 DEVICE

o RI=IEY
Build | Version Contol | Find in Files MPLABICD 2 |

Prograrmming Target...

Malidating configuration fields

[COWaml046: Because clock switching is enabled, MPLAB ICD 2 requires the user to cycle target power after
..Erasing Far

-Programming Fragram Mermary (0x0 - 0x4FF)
“erifying...

.Program Memary

Merity Succeeded

..Loading DebugExecutive

.Programming DebugExecutive

..Debug Executive

.Programming Debug Yector

..Debug Vector

.Programming Configuration Bits

.. Caonfig Mermory

“erifying confiquration memory...

Connecting to debug executive
.Prograrmming succeeded

O8-tdan~2008, 11:50:04

L4
1| | 3

2. Observe the process in the Output window. When MPLAB ICD 2 Ready appears,
the device is programmed and ready to run.

3. Select Debugger>Reset to reset the code.
4. Select Debugger>Run to run the code.

s
—
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3.5 DEBUGGING THE CODE

The MPLAB ICD 2 In-Circuit Debugger can be used to run, halt, and step the code. A
breakpoint can be set to halt the program after the code has executed the instruction
at the breakpoint. The contents of the RAM and registers can be viewed whenever the
processor has been halted.

The MPLAB ICD 2 In-Circuit Debugger uses the following function keys to access the
main debugging functions:

* <F5>— Halt

¢ <F6> — Reset

* <F7> - Single Step
¢ <F9> — Run

In addition to these, there are more functions accessible by right clicking on a line of
source code. The most important of these are “Set Breakpoint” and “Run to Cursor”.

351 Displaying the Code

To display the code:

1. Select View>Program Memory.

2. From the Program Memory window, select the Symbolic tab, as shown in
Figure 3-20.

FIGURE 3-20: PROGRAM MEMORY WINDOW
-l x|
Line Lddress Opcode Lakel I Disasse
= 1 oooo 040200 goto _reset o
2 oooz oooooo nop

3 ooo04 oo04AC _DefaultInterrupt

4 ooos oo04AcC _DefaultInterrupt

= Qoos ooo4nc _DefaultInterrupt

& ooon oo04AC _DefaultInterrupt

7 oooc OO0 AC _DefaultInterrupt

a8 OO0E o004 AC _DefaultInterrupt

=] ogio oo04AC _DefaultInterrupt

10 [ oo04AC _DefaultInterrupt

11 o014 oo04AcC _DefaultInterrupt

12 Qo01e ooo4nc _DefaultInterrupt

13 oo1s oo04Ac _DefaultInterrupt

14 oo1a oaosD4 _TlInterrupt

15 ooic oo04AC _DefaultInterrupt

16 O01E OO0 AC _DefaultInterrupt

17 ooz0 oo04AC _DefaultInterrupt

15 oozz oo04AC _DefaultInterrupt

19 o024 oo04AC _DefaultInterrupt

20 o026 oo04AcC _DefaultInterrupt

21 oozs ooo4nc _DefaultInterrupt

22 002 a oo04Ac _DefaultInterrupt

23 oozc OO0 AC _DefaultInterrupt

24 O0zZE O003E6S _ALDCInterrupt

Z5 ooso oo04AC _DefaultInterrupt

26 oo3z oo04AC _DefaultInterrupt

27 o034 oo04AC _DefaultInterrupt

2g o036 oo04AC _DefaultInterrupt

z29 oo3s oo04Ac _DefaultInterrupt
30 0034 0004 AC DefaultInterrupt r
l _>IJ

Opcode Hex | Maching || Symbolic PSY Mised | PSY Data
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3. Press <F5> to halt the processor and press <F6> to reset the processor. The
Program Memory now displays a green arrow pointing to the line of code at
address 0.

The instruction at this location is goto 0x000100. This code is added by the linker to
make the program branch to the start of the code in the main.c file. The executable
code starts from location 0x000100.

3.5.2 Stepping the Program

To step the program:

1. Press <F7> to single step the code. The green arrow now points to the code
below ACLKCONbits.ENAPLL = 1; inthe main.c source code, as shown in
Figure 3-21.

FIGURE 3-21: SOURCE CODE WINDOW

IDE Editor -10] x|
main. ¢ | ﬂ
S* Configure Oscillator to operate the device at 40Mhz j

Fosc= Fin*M/ (N1*NZ), Foy=FoscfE
Fozo= 7.37%043) F(E*2)1=80Mhe for Fosc, Feoy = 40Mhe */

Jf* Configure PLL prescaler, PLL postscaler, PLL divisor */
PLLFEBD=41; f* M = PLLFED + 2 */

CLEDIVbits. PLLPOST=0;  /* N1 = & */

CLEDIVbits. PLLPRE=0; fENE =2 %

__builtin write DSCCONHIOxOL); J* New Oszcillator selection FRC w/ FLL */

_ builtin write QECCONLI0xO0L); /% Enable Zwitch */

while (05CCONbits. COSC = 0Ob0OOL); J* Wait for Oscillator to switch to FREC w/ PLL */
while (03CCONbits LOCE != 1); f* Wait for PLL to Lock */

S* Now setup the ADC and PUM clock for 1EOMHzZ

((FRC * ley f APETECLRE ) = (7.37MHz * ley ;1 = 117.5MHz*/
ACLECONbit=. FRCSEL = 1; f* FRC provides input for luxiliary PLL (xlé) */
ACLECONbits. SELACLE = 1; f* Maxiliary Ocillator provides clock source for P & ADC
ACLECONbits APSTECLRE = 7; /% Divide Auxiliary clock by 1 *f
‘ | ACLECONbits EMAPLL = 1; /* Enshle Auxiliary PLL */
while (ACLECONbits APLLCE != 1); /* Wait for Auxiliary PLL to Lock */

[ | ol

2. Rightclick the instruction up to which the code is to be executed and select Run
to Cursor.

The program is executed up to the instruction selected.
3. Select View>Watch. The Watch window appears, as shown in Figure 3-22.
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FIGURE 3-22: WATCH WINDOW
Wi _lox]
Add SFHl IﬂDEDN v| Add Symhull |_SF‘ |
Updatel Lddress | Syrbol Name | Value | Decimal |
4z b DTR1 O=0000 a
420 PWMCCON] O=000oo a
J0a ADCON Ox4003 16387

Watch1 Watch2| watch3| watch 4|

4. Select DTR1 from the Add SFR drop-down list and click Add SFR to add the
DTR1 register in the Watch window.

5. Select PWMCONL1 from the Add SFR drop-down list and click Add SFR to add
the PWMCONL register in the Watch window.

6. Select ADCON from the Add SFR drop-down list and click Add SFR to add the
ADCON register in the Watch window.

You will be able to see these registers change as you step through the code.

3.5.3 Setting the Breakpoint

1. To set a breakpoint, right click a line of code and select Set Breakpoint from the
pop-up menu.
For example, find the following line of code and set a breakpoint on this line:
ACLKCONbits.FRCSEL = 1;

A red octagonal shape marked with a B appears in the gutter (gray bar on the
left) of the source code window to designate the breakpoint location, as shown
in Figure 3-23.
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FIGURE 3-23:

SETTING BREAKPOINT

Il MPLAE IDE Editor

main.c |

=10/ x]

f* Configqure Oscillator to operate the device at 40Mhz

Fozo= Fin*M/ (N1*NZ), Feoy=Fosc

f2

Fozo= 7.37%(43) /(E¥E)=80Mhz for Fosc, Foy = 40Mhe */

§* Configqure PLL prescaler, PLL postscaler, PLL divisor */f
FLLFED=41; f* M = PLLFED + Z */

CLEDIVbits. PLLPOET=0; /* Nl =
CLEDIVbits. PLLPRE=0; i NHE =

__builtin write OSCCONH(OxOL);
__builtin write OSCCONL(0x0OL);

while (0SCCONbits. COSC != 0BOOL) ;
while (0SCCONbits. LOCK != 1);

Z*f
Z*f

,,f'.\‘
,,f'.\‘

,,f'.\‘
,,f'.\‘

Hew Oscillator selection FREC w/ PLL */
Enable Switch */

Wait for Osecillator to switch to FRC wf PLL */

Wait for PLL to Lock *f

F* Now zetup the ADC and PUM clock for lZ0MHz
((FRC * le) / APETECLE ) = (7.37MHz * l&) / 1 = 117.0MHz*/

ACLECOMbits. FRCEEL = L;
ACLECONbits. SELACLE = 1;
ACLECONbits  APSTECLR = 7;
ACLECOMbits. ENAPLL = L;

while (ACLECONbits  APLLCK != 1);

,,f'.\‘
,,f'.\‘
,,f'.\‘
,,f'.\‘

,,f'.\‘

FRC provides input for Auxiliary PLL (xlé) *f
Auxiliary Ocillator provides clock source for P 4 ADC

Divide Auxiliary clock by 1 */f
Enable Auxiliary PLL *f

Wait for Auxiliary PLL to Lock */

-

> 1 lx

of

2. Press <F9> to run the code.

The program halts on the instruction following the breakpoint.

Note: An alternate method to set a breakpoint is to simply double click the line.
This feature may need to be enabled using the Edit>Properties menu.
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Chapter 4. Demonstration Program Operation

The Buck/Boost Converter PICtail Plus Daughter Board CD supplied with the
Buck/Boost Converter PICtail Plus Daughter Board consists of the source code for the
16-hit 28-pin Starter Development Board (Buck 1 stage only) and Explorer 16 Develop-
ment Board (Buck 1, Buck 2 and Boost stages). To demonstrate a program that illus-
trates PID control of the output voltage on the Daughter Board, program the device with
respective source code, available on the Daughter Board’s CD, specified in

Section 3.2 “Creating the Project”. The code can also be downloaded from the
Microchip web site (http://www.microchip.com).

The following topics are included in this chapter:

« Program Demonstration
« Code Demonstration
« Other Code Examples

4.1 PROGRAM DEMONSTRATION

The demonstration program provides simultaneous closed-loop control of the output
voltages.

The PID control scheme consists of the following parameters:

« Proportional Error Gain (P-Gain) — This parameter produces a correction factor
that is proportional to the magnitude of the output voltage error.

« Integral Error Gain (I-Gain) — This parameter uses the cumulative voltage error
to generate a correction factor that eliminates any residual error due to limitations
in offset voltages and measurement resolution.

« Derivative Error Gain (D-Gain) — This parameter produces a correction factor
that is proportional to the rate of change of the output error voltage, which helps
the system respond quickly to changes in system condition.

Additional control parameters that the user can add to P, | and D Gain terms are as
follows:

« Second Derivative, or Jerk Error, Gain (J-Gain) — This parameter produces a
correction factor that is proportional to the change in the differential error (i.e., the
derivative of the derivative). J-Gain is a high frequency term that tends to provide
quick response to an impulse event.

« Feed Forward Gain — This parameter produces a correction factor based on the
desired output voltage that is computed based on the magnitude of the input
voltage, inductor current, and circuit attributes (i.e., inductor and capacitor
values). This term allows the control loop to be proactive rather than reactive. In
other words, when the input voltage changes, feed forward gain responds so that
the control loop does not have to wait until the output voltage changes before
making the appropriate gain correction.
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FIGURE 4-1:

- Dead-Time Gain — This parameter produces a correction factor that compensates
for the fact that the feed forward gain term does not account for the energy lost
due to the dead time of the PWM signal (the time when both MOSFETSs are off).

« Current-Limit Gain — This parameter limits the cumulative control gain when the
current is approaching its upper limit.

After the modifications have been made to the 16-bit 28-pin Starter Development
Board, as specified in Section 2.4 “Using the Daughter Board with the 16-bit 28-pin
Starter Development Board”, do the following:

« Connect the power supply
« Connect the MPLAB ICD 2

« Connect the Buck/Boost Converter PICtail Plus Daughter Board

« Connect the 9V power supply to the 16-bit 28-pin Starter Development Board as
shown in Figure 2-5

Instructions for programming the dsPIC33FJ16GS502 SMPS device are provided in the
Readme file of the respective software folder. Chapter 4. “Demonstration Program
Operation” also describes how to program the dsPIC33FJ16GS502 device using the
MPLAB ICD 2. Figure 4-1 illustrates the program flow of the demonstration program.

Note: While using the Explorer 16 Development Board with the Daughter Board,
the output voltages Buckl1+, Buck2+ and Boost+ can be verified by
measuring at output terminals J4, J5 and J8 respectively.

SMPS DEMONSTRATION PROGRAM FLOW CHART

START

Initialization Routines:

« Peripherals — ADC, PWM, Timers, GPIO, etc.

« Variables — PID Gain Terms, Data Buffers

« Constants — Desired Voltage, Current Limit, etc.
¢ Interrupts — ADC, Timers

ADC Interrupt

ADC Interrupt Routines:
* Measure VouT

Soft Start Routine « Calculate PID Gain

e Update PWM Duty Cycle

. y Exit ISR
Idle Loop Functions: Wait for ADC Interrupt

Y
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4.2 CODE DEMONSTRATION

421 System Initialization

When power is applied to the board, the program starts by executing the following system
initialization routines:

« Peripherals — The required peripherals (PWM, ADC, Timers and GPIO) are
configured and enabled.

« Variables — Program variables are defined. RAM locations and register usage are
defined and documented.

« Constants — Program constants are defined including reference set points for
both VOUT1 and VOUT2, input voltage, current limits, fault conditions, PWM
periods and Timer periods.

« Interrupts — The ADC and Timer Interrupts are set up and enabled.

« System Stabilization — All outputs are discharged to ensure a stable value at
start-up.

4.2.2 Fault Check

The program checks the ADC for input undervoltage and output overvoltage conditions.
If a fault occurs, the PWM outputs are disabled until the fault condition is cleared. If no
fault is detected, the program proceeds.

4.2.3 Soft Start

The Soft Start Routine ramps up the output voltage in an open-loop fashion to bring the
system within the operating range of the PID control loop. This routine ensures that the
output does not overshoot the desired voltage. It also limits the current at start-up.

4.2.4 ADC Interrupt

The ADC Interruptis the heart of the demo program. This routine takes up approximately
75% of the execution time. It performs all the PID calculations and applies any needed
corrections to the output.

425 System Idle Loop

Note 1: The ADC Interrupt can occur any time during program execution.

2: The ADC Interrupt takes priority over any other tasks that the program is
performing.

All auxiliary functions are performed in the system idle routine. This is the time available
tothe CPU while the demo program is waiting for an ADC Interrupt. Non-critical functions
can be performed in this loop. During this time the input voltage, fault timers and Soft
Start flag are checked.

4.3 OTHER CODE EXAMPLES

There are several other code examples are available on the Microchip web site. Refer
to the Readme files located in each code example folder for details on what each code
example demonstrates. Check the Microchip web site (http://www.microchip.com) for
the latest updates to the code examples and for additional code examples.
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Appendix A. Schematics and Layouts

This appendix provides the board layout followed by schematics for the Buck/Boost
Converter PICtail Plus Daughter Board, which includes the following diagrams:

» Daughter Board Layout

« Daughter Board Schematic 1 of 5

» Daughter Board Schematic 2 of 5

» Daughter Board Schematic 3 of 5

« Daughter Board Schematic 4 of 5

» Daughter Board Schematic 5 of 5
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FIGURE A-2:

DAUGHTER BOARD SCHEMATIC 1 OF 5
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FIGURE A-3:

DAUGHTER BOARD SCHEMATIC 2 OF 5
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FIGURE A-4:

DAUGHTER BOARD SCHEMATIC 3 OF 5
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FIGURE A-5: DAUGHTER BOARD SCHEMATIC 4 OF 5
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FIGURE A-6:

DAUGHTER BOARD SCHEMATIC 5 OF 5
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Appendix B. Bill of Materials (BOM)

TABLE B-1:

BILL OF MATERIALS

This appendix provides the Bill of Materials (BOM) for the Buck/Boost Converter PICtalil
Plus Daughter Board.

DNP | Qty

Ref.

Description

Mfgr.

Mfgr. P art No.

4

C1o0,
C11,
C17,C18

SMD Tantalum Capacitors 150 pF 6V 10% D

AVX

TPSD157K006R0050

J4, J5,
J8g, J9

TERM BLOCK PCB 2POS 5.0MM GREEN

Pheonix Contact

1935161

C12,
C15,
C16,
C19,
C24,
C28, C8,
C9,,C4

CAP .1 pF 25V CERAMIC X7R 0805

Panasonic - ECG

ECJ-2VB1E104K

C20,
Ci4, C7

CAP CERM 2200PF 5% 25V NP0 0805

ACX Corp.

08053A222JAT2A

C5, C2,
C3

CAP 470PF 50V CERM CHIP 0805 SMD

Panasonic - ECG

ECJ-2VC1H471J

C29,
C30,
C25, C26

CAP CER 4.7 pF 25V X5R 1206

Taiyo Yuden

TMK316BJ475KL-T

C13,
C27, C6

220 pF 25V Elec Cap

Rubycon

2571.220M8X11.5

Cc22

CAP ELECT 100 pF 25V VS SMD

Panasonic - ECG

EEE-1EA101P

D3, D7

DIODE SCHOTTKY 1A 40V SMA

Fairchild Semiconductor

SS14

D10,
D15, D16

Schottky 3a, 30V Rectifier

Fairchild Semiconductor

SS33

J6, J12,
J13, J14,
J15

CONN HEADER 2POS .100" SGL GOLD

Samtec Inc

TSW-102-07-S-S

J2

CONN RCPT .100" 28POS DUAL GOLD

Samtec Inc

SSW-114-01-G-D

D11,
D12,
D13, D14

LED GREEN CLEAR 0805 SMD

LITE-ON INC

LTST-C170KGKT

R10,
R15,
R28,
R40, R43

RES 5.10 kOHM 1/8W 1% 0805 SMD

Rohm

MCR10EZHF5101

R11,
R56, R29

RES 3.30 kOHM 1/8W 1% 0805 SMD

Rohm

MCR10EZHF3301

© 2010 Microchip Technology Inc.
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TABLE B-1: BILL OF MATERIALS (CONTINUED)
DNP | Qty Ref. Description Mfgr. Mfgr. P art No.
5 |R20, RES 3.30 kOHM 1/10W 1% 0603 SMD Panasonic - ECG ERJ-3EKF3301V
R31,
R34,
R32, R33
2 |R12, R30|RES 4.99 kOHM 1/8W 1% 0805 SMD Rohm MCR10EZHF4991
4 |R13, RES 20.0 kOHM 1/8W 1% 0805 SMD Rohm MCR10EZHF2002
R24,
R55, R6
6 |R14, RES 2.20 kOHM 1/8W 1% 0805 SMD Rohm MCR10EZHF2201
R25, R7,
R47,
R57,
R58,
R37 RES 470 OHM 1/16W 1% 0805 SMD Panasonic - ECG ERJ-6ENF4700V
R22, RES 1.00 kOHM 1/8W 1% 0805 SMD Rohm MCR10EZHF1001
R39, R4,
R42, R54
2 |R23,R5 |[RES 20.0 OHM 1/8W 1% 0805 SMD Rohm MCR10EZHF20R0
5 |R26, RES 22.0 OHM 1/8W 1% 0805 SMD Rohm MCR10EZHF22R0
R27,
R52, R8,
R9
4 |R41, RES 10.0 KOHM 1/8W 1% 0805 SMD Rohm MCR10EZHF1002
R59,
R60, R45
1 |R53 RES .50 OHM 1W 1% 2512 SMD Vishay/Dale WSL2512R5000FEA
1 |R44 RESISTOR WIREWOUND 5.0 OHM 5W Ohmite 25J5R0E
2 (U1, U2 IC DVR HALF-BRIDGE HV 8-SOIC National Semiconductor | LM5101M/NOPB
4 1Q1,Q2, |30V N-CH Fast SwitCH PwrTrenCH Fairchild Semiconductor | FDS6298A
Q6, Q7 |MOSFET
1 |Q13 30V, 9A,11.5 OHM NCH POWER TR Fairchild Semiconductor | FDS6692A
1 [Q14 MOSFETs SOT-223 N-CH 30V Fairchild Semiconductor | FDT459N
7 |D1,D2, |DIODE SW 75V 215MA HS SOT23 NXP BAS16 T/R
D4, D5,
D6, D9,
D8
4 |Q11, Q4, | TRANS NPN 40V 0.8A SOT23 Fairchild Semiconductor | BSR14
Q3, Q8
1 |Q12 TRANS PNP 60V 0.8A SOT23 Fairchild Semiconductor | BSR16
4 |Buckl+, |TEST POINT PC MULTI-PURPOSE RED Keystone 5010
Buck2+,
Boost+,
VIN
4 | GND, TEST POINT PC MULTI-PURPOSE BLK Keystone 5011
GND,
GND,
GND
3 [J6,J12, [SHUNT LP W HANDLE 2 POS SN Tyco Electronics Amp | 4-881545-2
J13
2 |TX1, TX2 | SMT CUR SENSE XFMR CoilCraft CST1_060L
2 |L3, L4 INDUCTOR 10 pH 3.9A CoilCraft DO3316P-103ML
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Bill of Materials (BOM)

TABLE B-1: BILL OF MATERIALS (CONTINUED)
DNP | Qty Ref. Description Mfgr. Mfgr. P art No.

1 |L5 INDUCTOR 22 pH 2.7A CoilCraft D03316P-223ML
1 |U3 IC MOSFET DVR 1.2A DUAL HS 8SOIC Microchip Technology | TC1428COA

X D17, D18 | DIODE SCHOTTKY 30V 300MA SOT23 Micro Commercial Co. | BAT54S-TP

X J3 CONN HEADER 6 POS .100" SNGL TIN Samtec Inc TSW-106-05-T-S

X J11 CONN HEADER 2 POS .100" SGL GOLD Samtec Inc TSW-102-07-S-S

X R46 RESISTOR WIREWOUND 5.0 OHM 5W Ohmite 25J5R0E

X J10 CONN HEADER 2 POS .100" SGL GOLD Samtec Inc TSW-102-07-S-S

X RP1 POT 5.0 kOHM THUMBWHEEL CERM ST |Bourns Inc. 3352T-1-502

X R21 DNP — —

X R3 DNP — —

X TP3 DNP — —

X TP4 DNP — —

X TP5 DNP — —

X TP6 DNP — —

X TP7 DNP — —

X TP14 DNP — —

X TP15 DNP — —

X TP16 DNP — —

X R1, R2 DNP — —

X R35, R36 | DNP — —

© 2010 Microchip Technology Inc.
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