
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

CY4500 

 EZ-PD™ Protocol Analyzer Guide 
 

Doc. No. 002-12170 Rev. *C 

 

 

 

Cypress Semiconductor 

198 Champion Court 

San Jose, CA 95134-1709 

www.cypress.com 

 

 

http://www.cypress.com/


 Copyrights 
   

CY4500 EZ-PD™ Protocol Analyzer Guide, Doc. No. 002-12170 Rev. *C 2 

© Cypress Semiconductor Corporation, 2016-2017. This document is the property of Cypress Semiconductor Corporation 
and its subsidiaries, including Spansion LLC (“Cypress”).  This document, including any software or firmware included or 
referenced in this document (“Software”), is owned by Cypress under the intellectual property laws and treaties of the 
United States and other countries worldwide.  Cypress reserves all rights under such laws and treaties and does not, except 
as specifically stated in this paragraph, grant any license under its patents, copyrights, trademarks, or other intellectual 
property rights.  If the Software is not accompanied by a license agreement and you do not otherwise have a written 
agreement with Cypress governing the use of the Software, then Cypress hereby grants you a personal, non-exclusive, 
nontransferable license (without the right to sublicense) (1) under its copyright rights in the Software (a) for Software 
provided in source code form, to modify and reproduce the Software solely for use with Cypress hardware products, only 
internally within your organization, and (b) to distribute the Software in binary code form externally to end users (either 
directly or indirectly through resellers and distributors), solely for use on Cypress hardware product units, and (2) under 
those claims of Cypress’s patents that are infringed by the Software (as provided by Cypress, unmodified) to make, use, 
distribute, and import the Software solely for use with Cypress hardware products.  Any other use, reproduction, 
modification, translation, or compilation of the Software is prohibited. 

TO THE EXTENT PERMITTED BY APPLICABLE LAW, CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED, WITH REGARD TO THIS DOCUMENT OR ANY SOFTWARE OR ACCOMPANYING HARDWARE, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE. To the extent permitted by applicable law, Cypress reserves the right to make changes to this 
document without further notice. Cypress does not assume any liability arising out of the application or use of any product 
or circuit described in this document.  Any information provided in this document, including any sample design information 
or programming code, is provided only for reference purposes.  It is the responsibility of the user of this document to 
properly design, program, and test the functionality and safety of any application made of this information and any resulting 
product.  Cypress products are not designed, intended, or authorized for use as critical components in systems designed or 
intended for the operation of weapons, weapons systems, nuclear installations, life-support devices or systems, other 
medical devices or systems (including resuscitation equipment and surgical implants), pollution control or hazardous 
substances management, or other uses where the failure of the device or system could cause personal injury, death, or 
property damage (“Unintended Uses”).  A critical component is any component of a device or system whose failure to 
perform can be reasonably expected to cause the failure of the device or system, or to affect its safety or effectiveness.  
Cypress is not liable, in whole or in part, and you shall and hereby do release Cypress from any claim, damage, or other 
liability arising from or related to all Unintended Uses of Cypress products.  You shall indemnify and hold Cypress harmless 
from and against all claims, costs, damages, and other liabilities, including claims for personal injury or death, arising from 
or related to any Unintended Uses of Cypress products. 

Cypress, the Cypress logo, Spansion, the Spansion logo, and combinations thereof, WICED, PSoC, CapSense, EZ-USB, 
F-RAM, and Traveo are trademarks or registered trademarks of Cypress in the United States and other countries.  For a 
more complete list of Cypress trademarks, visit cypress.com.  Other names and brands may be claimed as property of their 
respective owners. 

 



 

CY4500 EZ-PD™ Protocol Analyzer Guide, Doc. No. 002-12170 Rev. *C 3 

Contents 
 

 

1. Introduction .................................................................................................................................................................... 6 

1.1 Analyzer Contents ................................................................................................................................................. 6 
1.1.1 Hardware Not Included With the Analyzer ................................................................................................ 6 

1.2 Getting Started ...................................................................................................................................................... 7 
1.2.1 CY4500 EZ-PD™ Protocol Analyzer Installation ...................................................................................... 7 

1.3 List of Recommended Hardware ........................................................................................................................... 7 
1.3.1 Recommended Host and Client Devices .................................................................................................. 7 
1.3.2 Recommended Adapters and Cables ....................................................................................................... 7 

2. Analyzer Installation ...................................................................................................................................................... 8 

2.1 CY4500 EZ-PD™ Protocol Analyzer Software Installation .................................................................................... 8 

3. CY4500 EZ-PD™ Protocol Analyzer Hardware .......................................................................................................... 12 

4. Analyzer Operation ...................................................................................................................................................... 15 

4.1 Capturing PD Packets Using CY4500 EZ-PD™ Protocol Analyzer ..................................................................... 15 
4.2 Updating PSoC 5LP Device Firmware on the CY4500 EZ-PD™ Protocol Analyzer ............................................ 18 

4.2.1 Updating Firmware Using EZ-PD Analyzer Utility ................................................................................... 18 

5. Appendix A: Terminology ........................................................................................................................................... 21 

Revision History ................................................................................................................................................................... 22 

Document Revision History ........................................................................................................................................... 22 
  

 

 

 

 

 

 

 

 

 

 

 



 

CY4500 EZ-PD™ Protocol Analyzer Guide, Doc. No. 002-12170 Rev. *C 4 

Safety Information 

 

 

The CY4500 EZ-PD™ Protocol Analyzer is intended for use as a development, demonstration, and debugging platform for 
hardware or software in a laboratory environment. The analyzer is not intended for general consumer use. It generates, 
uses, and can radiate radio frequency energy. It has not been tested for compliance with the limits applicable under any 
standard. Operation of the equipment may cause interference with radio communications, in which case users, at their own 
expense, will be required to take whatever measures may be required to correct this interference.  

Attaching additional wiring to this product or modifying the product operation from the factory default may affect its 
performance and cause interference with other apparatus in the immediate vicinity. If such interference is detected, suitable 
mitigating measures must be taken.  

The CY4500 EZ-PD™ Protocol Analyzer as shipped from the factory has been verified to meet with requirements of CE as 
a Class A product. 

 

 

The CY4500 EZ-PD™ Protocol Analyzer board contains electrostatic discharge (ESD)- sensitive 
devices. Electrostatic charges readily accumulate on the human body and any equipment, which 
can cause a discharge without detection. Permanent damage may occur to devices subjected to 
high-energy discharges. Proper ESD precautions are recommended to avoid performance 
degradation or loss of functionality. Store unused CY4500 EZ-PD™ Protocol Analyzer board in the 
protective shipping package. 

 

End-of-Life/Product Recycling 

The end-of-life cycle for this analyzer is five years from the date of manufacture mentioned on the 
back of the box. Contact the nearest recycler to discard the analyzer. 

 

General Safety Instructions 

ESD Protection  

ESD can damage boards and associated components. If an ESD workstation is not available, use appropriate ESD 
protection by wearing an antistatic wrist strap attached to the chassis ground (any unpainted metal surface) on the board 
when handling parts. 
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Handling Boards 

The board provided with CY4500 EZ-PD™ Protocol Analyzer is sensitive to ESD. This also applies to the boards that are 
provided with a plastic casing when they are removed from the casing. Hold the boards only by the edges. After removing a 
board from the box/casing, place it on a grounded, static-free surface. Use a conductive foam pad, if available. Do not slide 
the board over any surface. 
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1.   Introduction 

 

 

Cypress’s CY4500 EZ-PD™ Protocol Analyzer supports protocol analysis of the USB-PD and USB Type-C specifications. It 
performs non-intrusive probing and captures accurate protocol messages on the CC line. This analyzer consists of 

Cypress’s programmable MCU (PSoC® 5LP), which monitors data on the CC lines and sends this data to the host 

application over a USB interface. The Type-C plug and Type-C receptacle on this analyzer provide a pass-through for the 
Power Delivery (PD) Packets transmitted between each Type-C PD connection. The processor MCU taps these Power 
Delivery Packets without disturbing the system and transfers them over the USB interface to a PC running the host 
application. 

1.1   Analyzer Contents 

The CY4500 EZ-PD™ Protocol Analyzer consists of the following contents: 

 CY4500 EZ-PD™ Protocol Analyzer board enclosed in a transparent casing 

 USB 2.0 Type-A to Micro-B Cable 

 Jumper wires (6 in number) 

 Quick Start Guide 

1.1.1   Hardware Not Included With the Analyzer 
The CY4500 EZ-PD™ Protocol Analyzer Guide references the CY4531 CCG3 EVK as a Type-C host device for all the 
examples covered in this document. While it is highly recommended to have the CY4531 CCG3 EVK as a Type-C host 
device, it is not required and can be replaced with any USB Type-C host device, such as a notebook with a Type-C port. 
The following items are not included with the Analyzer: 

 A USB Type-C host device (for example, a notebook with a Type-C port, CY4531 EZ-PD™ CCG3 Evaluation Kit 
(EVK)) and a USB Type-C client device. 

 Type-C Power Adapter that supports USB-PD. Recommended power adapters are listed in the Recommended 
Adapters and Cables section. 

 As an option, Type-C to DisplayPort/HDMI/VGA adapters that can be used as Type-C devices for running the 
examples in this user guide. Recommended adapters are listed in the Recommended Adapters and Cables section. 

 

  

http://www.usb.org/developers/powerdelivery/
http://www.usb.org/developers/usbtypec/
http://www.cypress.com/documentation/development-kitsboards/cy4531-ez-pd-ccg3-evaluation-kit?source=search&cat=software_tools
http://www.cypress.com/documentation/development-kitsboards/cy4531-ez-pd-ccg3-evaluation-kit?source=search&cat=software_tools
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1.2   Getting Started 

Once the steps to install the analyzer as described in Analyzer Installation chapter are completed, refer to the Analyzer 
Operation chapter for instructions on how to run a quick demonstration and observe analyzer functionality. 

1.2.1   CY4500 EZ-PD™ Protocol Analyzer Installation 
The CyInstaller installs the CY4500 EZ-PDTM Protocol Analyzer along with the EZ-PD™ Analyzer Utility software and all 
necessary CYUSB3.0 drivers. Refer to the Analyzer Installation chapter for more details. 

1.3   List of Recommended Hardware 

1.3.1   Recommended Host and Client Devices 
See Table 1-1 for different options on choosing USB Type-C host and client devices. This analyzer is not shipped with any 
of the listed devices. A Type-C Power Adapter is required to run the example in the Analyzer Operation chapter. 

Table 1-1. List of Recommended Host & Client Devices 

No. Description Manufacturer Vendor Link 

 Host Devices   

1 Apple MacBook Apple Apple Store Link 

2 Google Chrome book Google Google Store Link 

3 CY4501 CCG1 Development Kit (Host Board) Cypress Cypress Link 

4 CY4531 EZ-PDTM CCG3 EVK Cypress Cypress Link 

5 CY4541 EZ-PDTM CCG4 EVK Cypress Cypress Link 

 Client Devices   

1 Type-C Power Adapter that supports USB-PD Apple Apple Store Link 

2 Type-C to Digital AV Multiport Adapter Apple Apple Store Link 

3 CY4501 CCG1 Development Kit (Client Board) Cypress Cypress Link 

 

1.3.2   Recommended Adapters and Cables 
See Table 1-2 for different options to obtain a set of cables recommended to work with Type-C host/client devices. This 
analyzer is not shipped with these adapters or cables.  

Table 1-2. List of Recommended Adapters and Cables 

No. Description Manufacturer MPN Vendor Link 

1 Type-C to Display Port Adapter Belinda - Amazon Link 

2 Type-C to HDMI Adapter Cable Matters - Amazon Link 

3 Type-C to VGA Adapter Cable Matters - Amazon Link 

4 DisplayPort to DisplayPort Cable (6”, gold plated) Cable Matters 102005-6 Amazon Link 

5 Mini DisplayPort to DisplayPort Cable (3”, gold plated) Cable Matters 101007-BLACK-3 Amazon Link 

http://www.apple.com/macbook/
https://pixel.google.com/
http://www.cypress.com/documentation/development-kitsboards/cy4501-ccg1-development-kit
http://www.cypress.com/documentation/development-kitsboards/cy4531-ez-pd-ccg3-evaluation-kit
http://www.cypress.com/documentation/development-kitsboards/cy4541-ez-pd-ccg4-evaluation-kit
http://www.apple.com/shop/product/MJ262LL/A/apple-29w-usb-c-power-adapter
http://www.apple.com/shop/product/MJ1K2AM/A/usb-c-digital-av-multiport-adapter?fnode=92125290a6c51ef4ff433e6cd3f6b870903162f6f19cc3033cfe5ce713c2d09712f029a642f6345204c02a5464d847b932cd2ff807326b3906e8e9b50895c0626a0a07160a8dcf6198585de4d8ed50877fba7a8e7e1
http://www.cypress.com/documentation/development-kitsboards/cy4501-ccg1-development-kit
http://www.amazon.com/Belinda%C2%AEUSB-DisplayPort-Adapter-Aluminium-ChromeBook/dp/B0155APCN4
http://www.amazon.com/Cable-Matters-Adapter-Supporting-Resolution/dp/B00X4S5C7G
http://www.amazon.com/Cable-Matters-Thunderbolt-Compatible-Adapter/dp/B00X4S58LQ/ref=sr_1_1?ie=UTF8&qid=1463765983&sr=8-1&keywords=Cable+Matters%C2%AE+USB+3.1+Type+C+%28USB-C%29+to+VGA+Adapter+in+Black
http://www.amazon.com/gp/product/B005H3Q59U/ref=ox_sc_act_title_1?ie=UTF8&psc=1&smid=A1AMUYYA3CT6HJhttp://www.amazon.com/gp/product/B005H3Q59U/ref=ox_sc_act_title_1?ie=UTF8&psc=1&smid=A1AMUYYA3CT6HJ
http://www.amazon.com/Cable-Matters-DisplayPort-Thunderbolt-Compatible/dp/B00C7RIL3C/ref=pd_sim_pc_6?ie=UTF8&refRID=1QEH8T0R161NKW108VSJ
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2.   Analyzer Installation 

 

 

 

 

This chapter describes the steps to install the CY4500 EZ-PD™ Protocol Analyzer.  

2.1   CY4500 EZ-PD™ Protocol Analyzer Software Installation 

To install the analyzer software, follow these steps: 

1. Download the latest analyzer software setup CY4500Setup.exe file from the Cypress website 
http://www.cypress.com/CY4500. This package contains the software EZ-PD Analyzer Utility for running the analyzer 
and the relevant documentation (User Guide, Quick Start Guide, and Release Notes). Double-click on the executable 
to start the installation. Click Next when the screen shown in Figure 2-1 appears. 

Figure 2-1. CY4500 EZ-PD™ Protocol Analyzer Installer Screen 

 

 

2. Select the required Installation Type and click Next to start the install (Figure 2-2). For first-time installation, it is 
recommended that you select “Typical” as the Installation Type. 

 

 

 

http://www.cypress.com/CY4500
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Figure 2-2. Installation Wizard 

 

3. Accept the license agreement for the software components and click Next (Figure 2-3). 

Figure 2-3. License Agreement 

 

 

4. Figure 2-4 shows the installation progress. 
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Figure 2-4. Installation Progress 

 

 

5. Enter Contact Information or select Continue Without Contact Information and click Finish (Figure 2-5). 

Figure 2-5. Software Installation Complete 
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6. When installation is complete, you have the option to launch Cypress Update Manager (Figure 2-6) to ensure you 
have the latest software package. Click the Check for updates button at the bottom of the window. If “No Updates” 
appears adjacent to the CY4500 EZ-PD™ Protocol Analyzer, click the Exit button. If there are updates, click the 
Update button to download and install the latest analyzer package. 

Figure 2-6. Cypress Update Manager 

 

 

Note: You can launch the Cypress Update Manager at any time from Start > All Programs > Cypress > Cypress 
Update Manager. 

7. After the installation is complete, the contents are available at the following location: <Install 

Directory>\CY4500 EZ-PD Protocol Analyzer\1.0. 

Note: On the Windows 32-bit platform, the default <Install Directory> is C:\Program Files\Cypress; on the 

Windows 64-bit platform, it is C:\Program Files(x86)\Cypress. 
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3.   CY4500 EZ-PD™ Protocol Analyzer 
Hardware 

 

 

The CY4500 EZ-PD™ Protocol Analyzer consists of a PSoC 5LP controller that probes into the USB Type-C signals over 
I2C transpiring between the USB Type-C plug and receptacle, and then transfers them over to a host PC via a USB Micro-B 
cable. The EZ-PD Analyzer Utility must already be running on the host PC to receive these messages, decode them, and 
show them as an output. The block diagram for the CY4500 EZ-PD™ Protocol Analyzer board is shown in Figure 3-1. 

Figure 3-1: CY4500 EZ-PDTM Protocol Analyzer Hardware Block Diagram 

USB Type- C 

Receptacle
USB Type-

C PlugUSB Type- C Signals

PSoC 

Controller

CC 

Signals

VBUS 

Voltage & 

Current 

Sensing

USB Micro- B 

Receptacle

USB PD Packet to Host PC

 

The board comprises of a Type-C plug at one end and a Type-C receptacle at the other, which is used to connect to the 
Type-C device or system under test. The board is powered over the USB micro-B port, which provides 4V, 500mA. The 
board also consists of one LED to indicate the power status. Besides this, it has connector headers brought out for the 
GPIOs, CC lines, VBUS, and SBU lines from the USB-PD system. Figure 3-2, Figure 3-3 and Figure 3-4 show the front 
view, back view and side view of CY4500 EZ-PD™ Protocol Analyzer board respectively. Table 3-1 contains their detailed 
description. Headers J1 and J8 are located on the back side of the board. Users need to take precaution and ensure that 
the exposed header pins of J1 and J8 do not get shorted. Shorting these exposed pins may result in a functional failure or 
unexpected behavior of the CY4500 EZ-PD™ Protocol Analyzer. 
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Figure 3-2: CY4500 EZ-PD™ Protocol Analyzer Board (Front View) 

 

 

Figure 3-3. CY4500 EZ-PDTM Protocol Analyzer Board (Back View) 

 

 

Figure 3-4. CY4500 EZ-PDTM Protocol Analyzer Board (Side View) 
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Table 3-1: CY4500 EZ-PD™ Protocol Analyzer Board Interfaces 

Connector Description 

J1 

USB Type-C Signal Header 

Pin 1: CC1 

Pin 2: CC2 

Pin 3: SBU1 

Pin 4: SBU2 

Pin 5: VBUS 

Pin 6: GND 

J2 Type-C Receptacle 

J3 Type-C Plug 

J7 USB Micro-B Connector 

J8 

Message Trigger Header 

Pin 1: SOM 

Pin 2: EOM 

Pin 3: MTR 

 

Note 1: Pins of header J8 are used for the triggering functionality. They can be connected using the jumper cables provided 
with the kit to an oscilloscope or other hardware that needs to be triggered. See the EZ-PDTM Analyzer Utility User Guide’s 
section 2.3 for more details on how to use this functionality. 

Note 2: The EZ-PD™ Protocol Analyzer Board is protected using a transparent casing. The board should not be removed 
from the casing any time while using the Analyzer.  

 

http://www.cypress.com/file/300601/download
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4.   Analyzer Operation 

 

 

This chapter describes how to run the CY4500 EZ-PD™ Protocol Analyzer with the EZ-PD Analyzer Utility and also how to 
update the firmware of the PSoC 5LP device of the analyzer. You must complete the installation procedure explained in the 
Analyzer Installation chapter before proceeding.  

4.1   Capturing PD Packets Using CY4500 EZ-PD™ Protocol Analyzer 

The steps to run the CY4500 EZ-PD™ Protocol Analyzer in order to capture the Power Delivery Packets on the CC bus are 
as follows: 

1. Using a USB Micro-B cable, connect the USB Micro-B receptacle (Connector J7) of the CY4500 EZ-PD™ Protocol 
Analyzer board to the host PC. LED1 of the CY4500 EZ-PD™ Protocol Analyzer board starts blinking in white 
color. 

2. Connect the USB Type-C plug (Connector J3) of the CY4500 EZ-PD™ Protocol Analyzer board to the Type-C host 
device. In this user guide, the CY4531 EZ-PD™ CCG3 Evaluation Kit (EVK) (not provided with this analyzer) is 
used as a Type-C host device as an example.  

3. Verify that your setup looks similar to the image shown in Figure 4-1.  

Figure 4-1: Setup for Operating CY4500 EZ-PD™ Protocol Analyzer 

 

4. On the host PC, launch the EZ-PD Analyzer Utility from Start > All Programs > Cypress EZ-PD Analyzer 

Utility. The EZ-PD Analyzer Utility’s start-up page will look similar to the image shown in Figure 4-2. 

To Host PC Running 

EZ-PD Analyzer Utility

http://www.cypress.com/documentation/development-kitsboards/cy4531-ez-pd-ccg3-evaluation-kit?source=search&cat=software_tools
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Figure 4-2: EZ-PD Analyzer Utility Start-up Page 

 

5. Click on the Start Capturing icon . The icon changes to the Stop Capturing icon . Alternatively, you can 
start capturing data by clicking on Actions > Start Capturing from the menu bar. The status bar at the bottom of 
the utility window shows the message “EZ-PD Analyzer is running” (similar to the status bar at the bottom of Figure 
4-4). 

6. Connect a USB Type-C power adapter (not provided with the analyzer) to the USB Type-C receptacle (Connector 
J2) of the CY4500 EZ-PD™ Protocol Analyzer board. Verify that your setup looks similar to the image shown in 
Figure 4-3. The USB Type-C power adapter mentioned here is just an example. Any USB Type-C device can be 
used in its place.  
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Figure 4-3: Completing the Setup for Operating CY4500 EZ-PD™ Protocol Analyzer 

 

7. Upon connecting the USB Type-C power adapter, the utility running on the host PC automatically displays a string 
of messages on the screen. Make sure that the hardware connections are not loose or do not get disconnected in 
the middle of a data capturing event. The running EZ-PD Analyzer Utility, along with the messages, will look similar 
to the image shown in Figure 4-4. 

Figure 4-4: EZ-PD Analyzer Utility Showing PD Packets Captured on CC Line 
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8. The EZ-PD Analyzer Utility displays the messages that have been captured (sent and received) between the USB 

Type-C host device and the USB Type-C client device on the CC line. Click on the  icon to stop capturing 
messages. Alternatively, you can stop capturing data by clicking on Actions > Stop Capturing from the menu bar. 
Upon clicking this icon, the status bar at the bottom of the utility window displays EZ-PD Analyzer is stopped. 

9. You can save the captured set of messages by clicking on File > Save. These files can be saved in the .ccgx,  
.xlsx or .csv formats, but only the file saved in .ccgx format can be opened using the EZ-PD Analyzer Utility by 
clicking File > Open. 

10. To clear a captured group of messages, you can either click the Clear Data  icon or click on Actions > Clear 
Data from the menu bar. This clears all the captured group of messages. If they are not saved prior to clicking the 
Clear Data icon, then these messages are lost. 

11. If the hardware shown in Figure 4-3 is not stable or gets disconnected at any point, the status bar at the bottom of 
the utility window shows the message EZ-PD Analyzer is disconnected. 

12. For more information on how to use the EZ-PD Analyzer Utility, refer to the EZ-PD™ Analyzer Utility User Manual 
by clicking Help > User Manual. 

4.2   Updating PSoC 5LP Device Firmware on the CY4500 EZ-PD™ 
Protocol Analyzer 

The firmware of the PSoC 5LP device present on the CY4500 EZ-PD™ Protocol Analyzer board can be updated using the 
EZ-PD Analyzer Utility. 

4.2.1   Updating Firmware Using EZ-PD Analyzer Utility 
1. Using a USB Micro-B cable, connect the USB Micro-B receptacle (Connector J7) of the CY4500 EZ-PD™ Protocol 

Analyzer board to the host PC. LED1 of the CY4500 EZ-PD™ Protocol Analyzer board starts blinking in white 
color. 

2. On the host PC, launch the EZ-PD Analyzer Utility from Start > All Programs > Cypress EZ-PD Analyzer Utility. 

The utility’s start-up page will look similar to the image shown in Figure 4-2. 

3. Check the current firmware loaded on the EZ-PD Protocol Analyzer Hardware by selecting Actions > Get 
Firmware Version as shown in Figure 4-5. 

Figure 4-5: Get the current firmware version 

 

 

4. Wait for the firmware version dialog box to appear as shown in Figure 4-6.  
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Figure 4-6: Firmware version dialog box 

 

Click OK to return to the main menu. Proceed with rest of the procedure to download the firmware incase a newer 
version of the firmware is available. 

5. Click on Actions > Download Firmware to initiate the firmware update. If the analyzer hardware is not connected, 
the status bar at the bottom of the utility window shows the message EZ-PD Analyzer is not connected. Ensure 
that the board connections are secure. If the utility window has any unsaved messages, a new window will pop up 
with a message “Data is about to clear from the window. Do you want to save?”. Users can select Yes or No based 
on their requirement. 

6. Upon executing step 5, a new window, Download firmware, opens as shown in Figure 4-7. The device enters the 
bootloader mode by default.  

Figure 4-7: “Download Firmware” Window 

 

7. Click Load File… as shown in Figure 4-7 and select the CY4500 firmware file in .cyacd format as shown in Figure 

4-8. Click Open. The binary file provided with the analyzer is available at the following location: <Install 
Directory>\CY4500 EZ-PD Protocol Analyzer\1.0\Firmware. 

Note: On a Windows 32-bit platform, the default <Install Directory> is C:\Program Files\Cypress; on the 

Windows 64-bit platform, it is C:\Program Files(x86)\Cypress. 
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Figure 4-8. Selecting the CY4500 Firmware File 

 

8. Click Program to initiate the firmware download process as shown in Figure 4-9. 

Figure 4-9. Initiating Firmware Download 

 

9. This starts the firmware download process. Click Exit when complete as shown in Figure 4-10. 

Figure 4-10. Completion of Firmware Download 

 

10. The steps to update the firmware are now complete. The CY4500 EZ-PDTM Protocol Analyzer hardware restarts 
with the firmware used in step 7 and is ready to use. 
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5.   Appendix A: Terminology  

 

 

This guide assumes that the user of the CY4500 EZ-PD Protocol Analyzer is familiar with the fundamentals of Type-C 
connectivity and the USB Power Delivery protocol. A brief description of Type-C terms is provided here for reference. 

 Alternate Modes: A feature of a USB Type-C system whereby one or both of the SuperSpeed lanes may be repurposed 
for use with a different serial protocol, such as a DisplayPort, eSATA, or Thunderbolt. 

 Client Device: A USB peripheral such as a hub, docking station, or monitor. 

 Configuration channel (CC): A USB Type-C bus wire used to transmit protocol signals. This is a half-duplex 300-kHz 
signal.  

 Consumer: A Type-C port that sinks power from VBUS. 

 DisplayPort: A digital display interface standard developed by the Video Electronics Standards Association. It is used 
primarily to connect a video source to a display such as a computer monitor. 

 Downstream facing port (DFP): A USB Type-C port on a host or a hub to which devices are connected.  

 Dp, Dn: USB Type-C bus wires used to transmit and receive USB 2.0 data. 

 Dual-role port (DRP): A USB Type-C port that can operate as either a DFP or a UFP. 

 Electronically Marked Cable Assembly (EMCA): A USB cable that includes an IC that reports cable characteristics 
(such as current rating) to the Type-C ports.  

Figure 5-1. Type-C Plug & Receptacle pins 
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 Host Device: A USB Host system such as a PC, notebook, laptop, and so on.  

 Provider: A Type-C port that sources power over VBUS.  

 Sideband use (SBU): A USB Type-C bus wire used for non-USB control signals, such as DisplayPort control signals. 

 Type-C Transceiver: A transmitter/receiver that communicates over the CC. 

 TX1p, TX1n, RX1p, RX1n, TX2p, TX2n, RX2p, and RX2n: USB Type-C bus wires used to transmit and receive 
SuperSpeed USB and PCIe or DisplayPort data. 

 Upstream facing port (UFP): A USB Type-C port on a device or a hub that connects to a host or the DFP of a hub. 

 USB Power Delivery (USB PD, PD): A new USB standard that increases maximum power delivery over USB from 
7.5 W to 100 W. 

 USB Type-C (Type-C): A new standard with a slimmer USB connector and a reversible cable, capable of sourcing up 
to 100 W of power and supporting Alternate Modes. 

 VBUS: A USB Type-C bus wire used for power; initially 5 V, but increased up to 20 V on USB PD systems. 

 VCONN: A USB Type-C bus wire used to power the IC in the EMCA.  
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